Commit 92580bfc authored by Paolo G. Giarrusso's avatar Paolo G. Giarrusso

Correct usage instructions: replace `Require` with `Require Import`

The fact that `Require` seems to work is a misfeature
(https://github.com/coq/coq/issues/12206). Worse, unlike you'd expect from
`Require`, indirect `Require` doesn't work.
parent a1001839
......@@ -16,10 +16,10 @@ Then install with `opam install coq-iris-string-ident`.
## Usage
Simply require this file before using the feature in the proof mode:
Simply import this file before using the feature in the proof mode:
```coq
From iris_string_ident Require ltac2_string_ident.
From iris_string_ident Require Import ltac2_string_ident.
From iris.proofmode Require Import tactics intro_patterns.
Lemma sep_demo {PROP: sbi} (P1: PROP) (P2 P3: Prop) (Himpl: P2 -> P3) :
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment