Commit a2efc56b authored by Robbert's avatar Robbert

Merge branch 'ralf/drop-old-coq' into 'master'

drop Coq 8.7 and add 8.10

Closes #242

See merge request !320
parents ee807b2f 5ac5746f
Pipeline #20779 passed with stage
in 15 minutes and 37 seconds
......@@ -34,11 +34,17 @@ build-coq.dev:
OPAM_PINS: "coq version dev"
CI_COQCHK: "1"
build-coq.8.10.dev:
build-coq.8.10.1:
<<: *template
variables:
OCAML: "ocaml-base-compiler.4.07.0"
OPAM_PINS: "coq version 8.10.dev"
OPAM_PINS: "coq version 8.10.1"
build-coq.8.10.0:
<<: *template
variables:
OCAML: "ocaml-base-compiler.4.07.0"
OPAM_PINS: "coq version 8.10.0"
build-coq.8.9.1:
<<: *template
......@@ -60,8 +66,3 @@ build-coq.8.8.2:
<<: *template
variables:
OPAM_PINS: "coq version 8.8.2"
build-coq.8.7.2:
<<: *template
variables:
OPAM_PINS: "coq version 8.7.2"
......@@ -18,7 +18,7 @@ definitions and some derived forms is available in
This version is known to compile with:
- Coq 8.7.2 / 8.8.2 / 8.9.0 / 8.9.1
- Coq 8.8.2 / 8.9.0 / 8.9.1 / 8.10.0 / 8.10.1
- A development version of [std++](https://gitlab.mpi-sws.org/iris/stdpp)
For a version compatible with Coq 8.6, have a look at the
......
......@@ -11,6 +11,6 @@ build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-rf" "%{lib}%/coq/user-contrib/iris"]
depends: [
"coq" { (= "8.7.2") | (= "8.8.2") | (>= "8.9" & < "8.12~") | (= "dev") }
"coq" { (= "8.8.2") | (>= "8.9" & < "8.12~") | (= "dev") }
"coq-stdpp" { (= "dev.2019-10-07.0.e35c9837") | (= "dev") }
]
......@@ -1507,9 +1507,5 @@ Section sigTOF.
End sigTOF.
Arguments sigTOF {_} _%OF.
(*
FIXME: Notation disabled because it causes strange conflicts in Coq 8.7.
Enable again once we drop support for that version.
Notation "{ x & P }" := (sigTOF (λ x, P%OF)) : oFunctor_scope.
Notation "{ x : A & P }" := (@sigTOF A%type (λ x, P%OF)) : oFunctor_scope.
*)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment