Commit 4d5898cb authored by Your Name's avatar Your Name

Fix `opam` file; remove 8.7.1 and 8.7.0 CI.

parent 75be6452
......@@ -33,23 +33,28 @@ variables:
build-coq.8.8.1:
<<: *template
variables:
OPAM_PINS: "coq version 8.8.1 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_88_COMMIT"
OPAM_PINS: "coq version 8.8.1 coq-mathcomp-ssreflect version 1.7.0 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_88_COMMIT"
TIMING_PROJECT: "iris"
TIMING_CONF: "coq-8.8.1"
tags:
- fp-timing
build-coq.8.7.2:
build-coq.8.8.0:
<<: *template
variables:
OPAM_PINS: "coq version 8.7.2 coq-mathcomp-ssreflect version 1.6.4 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_87_COMMIT"
OPAM_PINS: "coq version 8.8.0 coq-mathcomp-ssreflect version 1.7.0 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_88_COMMIT"
build-coq.8.7.1:
build-coq.8.7.2:
<<: *template
variables:
OPAM_PINS: "coq version 8.7.1 coq-mathcomp-ssreflect version 1.6.4 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_87_COMMIT"
OPAM_PINS: "coq version 8.7.2 coq-mathcomp-ssreflect version 1.6.4 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_87_COMMIT"
build-coq.8.7.0:
<<: *template
variables:
OPAM_PINS: "coq version 8.7.0 coq-mathcomp-ssreflect version 1.6.4 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_87_COMMIT"
# build-coq.8.7.1:
# <<: *template
# variables:
# OPAM_PINS: "coq version 8.7.1 coq-mathcomp-ssreflect version 1.6.4 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_87_COMMIT"
#
# build-coq.8.7.0:
# <<: *template
# variables:
# OPAM_PINS: "coq version 8.7.0 coq-mathcomp-ssreflect version 1.6.4 coq-mtac.dev git https://github.com/Mtac2/Mtac2#$MTAC2_87_COMMIT"
......@@ -10,8 +10,8 @@ build: [make "-j%{jobs}%"]
install: [make "install"]
remove: ["rm" "-rf" "%{lib}%/coq/user-contrib/iris"]
depends: [
"coq" { (>= "8.6.1" & < "8.8~") | (= "dev") }
"coq" { (>= "8.6.1" & < "8.9~") | (= "dev") }
"coq-mtac"
"coq-mathcomp-ssreflect" { (>= "1.6.1" & < "1.7~") | (= "dev") }
"coq-mathcomp-ssreflect" { (>= "1.6.1" & < "1.8~") | (= "dev") }
"coq-stdpp" { (= "1.1.0") | (= "dev") }
]
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment