Commit 02aea1de authored by Heiko Becker's avatar Heiko Becker

Update to Coq 8.8.2 and opam 2

parent ffff3722
FROM debian:latest
FROM ocaml/opam2:latest
WORKDIR /root
USER root
#Necessary packages for opam
RUN apt-get update && \
apt-get install -y build-essential aspcud m4 wget unzip git
apt-get install -y build-essential aspcud m4 wget unzip git curl
# Install opam
RUN wget https://raw.github.com/ocaml/opam/master/shell/opam_installer.sh -O - | sh -s /usr/local/bin
# # Configure opam
# RUN opam init --comp=4.05.0 --auto-setup && \
RUN eval `opam config env`
# Configure opam
RUN opam init --comp=4.05.0 --auto-setup && \
eval `opam config env`
RUN cd /home/opam/opam-repository && git pull && cd
# Install coq and dependencies
RUN opam repo add coq-released https://coq.inria.fr/opam/released && \
RUN opam repo add coq-released https://coq.inria.fr/opam/released --set-default && \
opam update
#Install coq 8.7.2 in a switch
RUN opam switch -A 4.05.0 coq8.7.2
RUN opam switch create coq8.7.2 ocaml-base-compiler.4.05.0 && \
eval `opam config env`
RUN opam install coq.8.7.2 coq-flocq.2.6.1
#Install coq 8.8 in a switch
RUN opam switch -A 4.05.0 coq8.8
RUN opam install coq.8.8.0 coq-flocq.2.6.1
RUN opam switch create coq8.8 ocaml-base-compiler.4.05.0
RUN opam install coq.8.8.2 coq-flocq.2.6.1
# Install polyml from git
RUN git clone https://github.com/polyml/polyml.git polyml && \
......
......@@ -28,8 +28,12 @@ case "$coq_ver" in
;;
8.8.0)
;;
8.8.1)
;;
8.8.2)
;;
*)
echo "Error: Need 8.7.2"
echo "Error: Need one of Coq 8.7.2, 8.8.0 8.8.1 or 8.8.2"
exit 1
esac
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment